System Performance Issue

Incident Report for Land Gorilla Status Page

Postmortem

Root Cause

During a planned configuration update to our account records at approximately 9:55 AM PST, an unintended consequence resulted in the clearing of cached ‘plan’ configurations. As users attempted to access the Land Gorilla application, the sudden surge in queries exceeded the system's immediate processing capacity. This overload led to performance issues, including slow loading times and, for some users, the inability to access the system.

Remediation Steps

Our engineering team immediately identified the increase in system load and quickly diagnosed the root cause.  Preventative measures have been planned to prevent this specific event from happening again.

Posted May 01, 2025 - 17:25 PDT

Resolved

This incident has been resolved.
Posted May 01, 2025 - 17:12 PDT

Monitoring

Some users have reported sporadic system performance latency and inability to access the Land Gorilla System. Our team has identified the issue and have deployed a solution. We will continue to actively monitor performance.
Posted Apr 30, 2025 - 12:55 PDT
This incident affected: Applications (Land Gorilla Client Application).