Lien Waiver Not Generating
Incident Report for Land Gorilla Status Page
Resolved
This incident has been resolved.
Posted Aug 24, 2023 - 09:10 PDT
Update
LevelSet has resolved the issue and the system's integrated lien waiver creation functionality has been restored.
Posted Aug 24, 2023 - 09:10 PDT
Update
LevelSet has identified the source of the issue and we are working with them on a resolution.
Posted Aug 22, 2023 - 11:10 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 22, 2023 - 08:01 PDT
Investigating
Some users are experiencing an issue when attempting to generate a lien waiver from LevelSet. The issue has been identified and we have reported the issue to the LevelSet integration team.  We will advise as soon as LevelSet resolves the issue.

As a workaround, a lien waiver can be generated directly here:  https://www.levelset.com/ > Get Paid > Send or Request Lien Waiver
Posted Aug 22, 2023 - 07:32 PDT
This incident affected: Applications (Land Gorilla Client Application, LevelSet).