Hello Sign Hello Work Products Update
Incident Report for Land Gorilla Status Page
Resolved
Windows time is closed by now, closing the status page and the ticket
Posted May 12, 2022 - 13:24 PDT
Monitoring
The team has been notified that the scheduled maintenance has been completed.
Posted May 12, 2022 - 12:05 PDT
Investigating
HelloSign will be performing Schedule maintenance in the next few hours Expect delays or malfunctions as a consequence

From Hello Sign

HelloWorks Product Update



Maintenance update

Maintenance will begin as scheduled in 60 minutes.
Posted May 12, 2022 - 10:10 PDT
This incident affected: Applications (Land Gorilla Client Application, HelloSign).